Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6482
    Lihanwei007
    lihanwei007
    Participant

    Why I still get the message: Could not load file or assembly ‘System.Data.SQLite.dll’ or one of its dependencies after I download and run the file VSU_4\vcredist_x64.exe
    Thank you very much!

    #6483
    Leonardo Frid
    Leonardo Frid
    Keymaster

    Did you already try the following from our installation instructions page:

    If you get the message Could not load file or assembly ‘System.Data.SQLite.dll’ or one of its dependencies then you are missing a required Microsoft update. To fix the problem, go to https://www.microsoft.com/en-ca/download/details.aspx?id=30679, click Download, and then select and run the file VSU_4\vcredist_x64.exe

    If you did and still have the problem, could you please tell me what version of SyncroSim you are using?

    Thanks,
    Leonardo

    #6485
    Lihanwei007
    lihanwei007
    Participant

    I have installed VSU_4\vcredist_x64.exe.My SyncroSim version is 2.0.42.But I still get the error message.
    Last month I download version 2.0.33 in anotehr computer. There was the same problem after I run VSU_4\vcredist_x64.exe. But suddenly, it was solved after trying to create new library again and again.I don’t know why.
    And my system is Windows 7.

    thank you
    Hanwei

    #6545
    Leonardo Frid
    Leonardo Frid
    Keymaster

    Hi Hanwei,

    First of all, my apologies for the delayed reply. Second, here are some new things to try:

    The link higher up in the thread is out of date. It should be:

    https://www.microsoft.com/en-us/download/details.aspx?id=53587

    And also, you must have “Service Pack 1” of Windows 7 according to this page. Note that SP1 should be installed before installing SyncroSim because (I suspect) that the setup pack’s “VC ++ Merge Module” installer will silently not work if you don’t have at least this version.

    Please try these steps and let us know if that resolves your problem.

    Regards,
    Leonardo

    #6610
    Lihanwei007
    lihanwei007
    Participant

    Hi Leonardo,
    I tried your step and my problem has been solved. Thanks for your help.
    My apologies for the delayed reply because of the business travel.
    Best wishes,
    Hanwei.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.